Reliance DataCard on Ubuntu

First of all create a file /etc/wvdial.conf
vi /etc/wvdial.conf

[Modem0]
Modem = /dev/ttyUSB0
Baud = 115200
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
FlowControl = Hardware (CRTSCTS) [Dialer cdma]
Username = 
Password =
Phone = #777
Stupid Mode = 1
Inherits = Modem0
I had connected datacard before booting my system.
(I have enabled root login):
I executed following commands.
#lsusb
It listed many things along with my new reliance usb datacrd.
(
Bus 006 Device 019: ID 12d1:1411 Huawei Technologies Co., Ltd. )
then,
#wvdial cdma
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT 153600
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Dec 13 09:04:51 2008
--> Pid of pppd: 6410
--> Using interface ppp0
--> pppd: `?[13] `?[13] ??[13]
--> pppd: `?[13] `?[13] ??[13]
--> pppd: `?[13] `?[13] ??[13]
--> pppd: `?[13] `?[13] ??[13]
--> pppd: `?[13] `?[13] ??[13]
--> pppd: `?[13] `?[13] ??[13]
--> local IP address 220.226.118.181
--> pppd: `?[13] `?[13] ??[13]
--> remote IP address 220.224.135.79
--> pppd: `?[13] `?[13] ??[13]
--> primary DNS address 202.138.103.100
--> pppd: `?[13] `?[13] ??[13]
--> secondary DNS address 202.138.96.2
--> pppd: `?[13] `?[13] ??[13]
Now minimized the terminal and started firefox (work offline has to be disabled). It worked.
(For disconnecting I use ctrl+c in the terminal. can anyone suggest the correct method?)
.
.
If datacard inserted after booting of Ubuntu, command #lsusb didn’t show the datacard.
I executed
#modprobe usbserial
after sometime,
#lsusb 
it worked. (I am not sure ubuntu automatically deteced it or ‘modprobe’ command did it).
Then as usual
#wvdial cdma
You will get the similar output as shown above then minimize the screen and browse internet.

1 comment:

  1. This comment has been removed by a blog administrator.

    ReplyDelete